[isabelle-dev] isabelle jedit quickly aborts

Jasmin Blanchette j.c.blanchette at vu.nl
Tue Jan 7 17:17:43 CET 2020

> I updated to Isabelle/ffb1783dd7e0 today, and since then I can't start Isabelle/jEdit. I've tried with a bare-bones settings file containing only
> 	init_components "$USER_HOME/.isabelle/contrib" "$ISABELLE_HOME/Admin/components/main"
> When I type "isabelle jedit", the Isabelle logo appears as usual, then a bunch of AWT warnings I'm used to ignore, and after some time (anywhere between 5 and 60 s it seems), the logo goes away and control returns to the command line.
> I've tried "isabelle jedit -f", to no avail.
> I'm running macOS Mojave (10.14.4).

Additional data points: The same issue arises with Isabelle2019 when I launch the interface using

	/Applications/Isabelle2019.app/Isabelle/bin/isabelle jedit

On the other hand, this invocation works fine:

	open /Applications/Isabelle2019.app/

I've tried rebooting, closing other applications (to free up resources), etc., but always seem to get this behavior.


More information about the isabelle-dev mailing list